100 Days of LotD | Day 4: The Onboarding (cont’d)

You can find the „100 Days of LotD“ mission statement [ here ].


Having set up the most important things yesterday, today’s task is to finish the onboarding of the necessary applications, settings etc. so that, hopefully, the remaining 96 days are ‚just using it‘.

The little things

Today I have encountered several more of the little annoyances and, while not all of them are important and/or could be fixed, I will not leave them unmentioned.

Time format and language

There seem to be some minor inconsistencies regarding the localisation. When I first installed KUbuntu, there were three settings to be made throughout the process pertaining to localisation:

  • Install language (I chose EN-US because that’s the most universal one and this blog post series was supposed to be in English)
  • Keyboard layout (I chose German because that’s what I have)
  • Time zone (I chose, or rather accepted the preset choice of, German time).

Some of these choices led to the current date being displayed in German, both on the clock pop-up and on the lock screen. The overall UI is English (there are no Plasma translations other than EN-US installed). The browsers are set to English (and only that) also.

What I would like to have (and know how to set up on Windows) is an English UI with German time zone, keyboard layout and numeric formats  (comma vs. full stop, currency symbol etc.). However, the config file says that it’s actually already set that way:

(Yeah, I am using PowerShell for that 😉 ) And LibreOffice Calc appears to respect the LANG and not the TIME setting:

After googling for ten minutes, it looks like I will just have to live with it and learn the US dates (yuck!) or switch the UI to de-DE altogether…

WiFi network priority

I have two WiFi SSIDs at home: The guest network that has a slightly better coverage in my study and the regular one that offers access to printers, my lab, my NAS (if it’s on) and other facilities. As I installed Linux, I used the guest network because the WPA2 password is less complex there. After the installation was complete and I went about setting up RDP, printers and the rest, I switched to the ‚production‘ WiFi.

However, this doesn’t seem to survive a reboot. Whenever I boot the Linux laptop it connects to the guest WiFi, regardless of coverage. Correcting this seems to have required a third party app in the past but was incorporated into NetworkManager some versions ago. To prioritise networks against each other, you need to run

nmcli connection modify <Prod-SSID> connection.autoconnect-priority 10

We’ll see if it sticks. It certainly appears to for the time being.

Unlock on random (?) screen

This is not a real annoyance, just a fun side effect. My laptop is connected to the USB dock and through that, to two external monitors. If it goes to sleep and wakes back up, there’s no telling on which monitor the unlock dialogue will appear. Yesterday it was on Built-In and External 1 (which is set as primary), today it’s External 2 with a sprinkling of External 1 but without the Built-In. Go figure.

Office

In spite of both GNOME and KDE having their proprietary but relatively feature-rich office suite available, the default choice of office on Linux seems to be LibreOffice.  openSUSE Tumbleweed boasts the bleeding edge LibreOffice 7, while KUbuntu embraces the more conservative approach, offering 6.4 per default.

I worked with LibreOffice and its now aged parent, OpenOffice, a great deal in the past, and was less than thrilled to have to do this on my personal laptop for an extended period of time. So I went hunting for alternatives and reviews found here and here actually turned up an office suite that at least looks like something a spoiled Office 2016/2019 user can put up with. I am talking about FreeOffice, the little freeware brother of SoftMaker Office.

One look at the screenshots tells me that I’ve got to try this one out. And if the freeware version should one day prove to be lacking features, $80 for a perpetual license is not that much – and covers the Windows version, too, should I want to abandon Linux after this experiment. But let’s start with the free one. A quick test of ‚PlanMaker‘ (the alternative to Excel or LibreOffice Calc) reveals two reasons to like it even more:

This guy seems to respect the locale set on the system. Did you spot the other reason already? It’s in the ‚Character‘ area. Which brings us to…

The most compatible fonts

As a decades-long Windows + MSOffice user who had more than their share of bad experiences regarding embedding fonts in Office documents, which fonts would one choose for their templates in order to make them as portable as ever possible? Right, the Office 97 dream team of Arial (sans serif, variable width), Times New Roman (serif, variable width) and Courier New (fixed width). Which is exactly what I settled upon decades ago.

Turns out, those fonts are under licence by Microsoft and as such cannot be distributed with, or indeed to, a Linux box. There seems to be an old WebFont package from MS containing these (along with Verdana and WingDings) but people seem to have mixed results installing it on Linux. Besides, ‚web fonts‘ make me think of low quality and embedding problems, especially if the package in question is 20 years old.

All the more astonishing that SoftMaker products not only allow for these fonts to be used in existing documents without substitution but also have them on board for new documents. They do not expose these fonts to the underlying OS, though: Installing FreeOffice does not make the MS fonts available in LibreOffice.

This settles the font discussion for today: I will be using SoftMaker for my office needs and continue using the default Microsoft typefaces instead of deciding on a new set of fonts, altering all my templates – and ultimately, making these fonts available on my Windows boxes from now on. Saved me hours. Thanks SoftMaker! I suppose there’s some sophisticated substitution at work there, not the actual fonts – but creating new documents that will work correctly on Windows is important.

Documents and Spreadsheets

As I wrote earlier, my level of personal Word + Excel usage hardly begins to scratch the surface of what these programs are capable of. I opened most recent versions of documents and spreadsheets I have worked on in the last months, and they all opened without issue, would calculate, print, export as pdf. This is 100% a go. Not having to put up with apps looking like their UI has been designed as the dinosaurs roamed the Earth sweetens the whole Linux deal even more. If only there was an email client looking that good and capable of what I need 🙁

Presentations

With PowerPoint, the difference between my personal and work use is quite the reverse to Word and Excel. Due to my community activities and the need to design and maintain my own templates and decks, my personal computing self is more of a PowerPoint power user than my consulting self. So i pulled out one of the more involved presentations and tried opening it both in SoftMaker Presentations 2018 and LibreOffice Impress 6.4. The result was about 90% in both cases but with different pieces missing.

LibreOffice:

  • forms formatting (shadows, fuzzy edges) was not present on all forms
  • WingDings special characters lost
  • 3D smart art (a lifecycle diagram) shown as the correct type of smart art, but without 3D

SoftMaker:

  • Some text fields are slightly larger than in PowerPoint so overlap with other elements
  • 3D smart art shown correctly but with fuzzy white background filling up most of the slide.

Both programs lack the ability to record voice while presenting but I *think* it’s fairly new to PowerPoint also so might even be present in the current SoftMaker variety. I’ve used that feature once or twice recently in PowerPoint so it hasn’t yet become a must-have for me.

Mind Mapping

I love mind maps. Not enough to shell out several hundred Euros for a MindJet product but enough to require this functionality on my workstation, personal or otherwise.

The Discover store offers FreePlane and Minder. FreePlane I know from several customer environments which led me to using it myself on my personal laptop. Minder looked slicker at first but kept crashing and for some reason it didn’t offer all the graphical features its GitHub page toutes.

I also tried VYM (View Your Mind) and it’s slightly easier to use than FreePlane (although whoever came up with the idea to use anything other than [Ins] for a new branch should think again). However, the import functionality is pretty basic (any formatting is stripped) so I’m sticking with FreePlane to be able to reuse (or indeed open) my existing mind maps.

Diagrams

A heavy Visio user at work, I came to like draw.io very much recently. And guess what – there is a Linux variant as well, albeit not in the Discover store. The .deb package from GitHub installs without issue, looks and works exactly like its Windows counterpart. This is a go!

Dev Stuff

Having set up the office stuff, it’s time to turn to the last (but not least) item on the list: PowerShell development.

git

Every time I need to use git on a new Linux machine, I am surprised to find that it’s actually not installed yet. I don’t know why, but I just expect git to be part of a Linux install, just like I expect traceroute to be part of a Linux install and am equally surprised every time that it’s not there either.

The package manager installed git 2.25.1 without further ado, it was recognised by VSCode and did not require any specific configuration to work against GitHub and my GitLab appliance at home which covers 100% of my personal use case.

Text editing

KUbuntu comes with Kate which looks pretty awesome and serves my needs in terms of syntax highlighting. I miss two things in Search though:

  • replace by [Ctrl]+H
  • search/replace in selection only

I eventually figured out the last one, though. There are two search/replace interfaces:

The one above the blue line pops up on [Ctrl]+F and has ’search in selection‘ available after you click ’settings‘ on the right. The other one has dynamic search but only in current file, open files or a folder.

PowerShell and VSCode

I tested some of my favourite modules and the PowerShell extension in VSCode and the PowerShell extension and everything works as expected.

VSCode managed to register itself as the default application for folders, but this was easy to rectify.

In the evening

A successful day of trying out stuff. My laptop is now set up, as far as I can see. This should be the last long post for the time being – I will use this computer and report everything that’s out of the ordinary.

Before I shut down my new laptop, I’d like to see how many ’snaps‘ found their way onto my new machine:

OK, Spotify I can tolerate, hiri and mailspring actually have been uninstalled after yesterday’s mail debacle so the folders can be deleted. Chrome and KeePass, I need to look into and either find a way to install as ‚regular packages‘ or accept their snappy nature and keep them that way.

Title image: Paul Brennan from Pixabay

1 Trackback / Pingback

  1. 100 Days of LotD | Day 0: The Time of the Year, The Lay of the Land – Evgenij Smirnov – IT Pro aus Berlin

Antworten

Deine E-Mail-Adresse wird nicht veröffentlicht.


*


Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.